This page is not yet fully available in your language. Make a gift to your community by translating it! Click here to start.
Önerilen tüm sürümler, her serinin en son yayımlanan sürümünü temel alır.

Desteklenen Yazılım Gereksinimleri

Joomla! 3x İçin Gereksinimler

Yazılım Önerilen Minumum Daha fazla bilgi
PHP[1]
(Magic Quotes GPC off)
5.6 or 7.0 + 5.3.10 https://secure.php.net
Desteklenen Veritabanları:
MySQL[2]
(InnoDB support required)
5.5.3 + 5.1 https://www.mysql.com
SQL Server 10.50.1600.1 + 10.50.1600.1 https://www.microsoft.com/sql
PostgreSQL 9.1 + 8.3.18 https://www.postgresql.org/
Desteklenen Web Sunucuları:
Apache[3]
(with mod_mysql, mod_xml, and mod_zlib)
2.4 + 2.0 https://www.apache.org
Nginx 1.8 + 1.0 https://www.nginx.com/resources/wiki/
Microsoft IIS[6] 7 7 https://www.iis.net

Desteklenmeyen Yazılım Gereksinimleri

Joomla! 1.6, 1.7 ve 2.5 İçin Gereksinimler - 31 Aralık 2014'te destek sona erdi

Yazılım Önerilen Minumum Daha fazla bilgi
PHP 5.6 5.2.4 https://secure.php.net
Desteklenen Veritabanları:
MySQL 5.0.4 + 5.0.4 https://www.mysql.com
SQL Server[5] 10.50.1600.1 + 10.50.1600.1 https://www.microsoft.com/sql
Desteklenen Web Sunucuları:
Apache[3]
(with mod_mysql, mod_xml, and mod_zlib)
2.2 + 2.0 https://www.apache.org
Nginx 1.1 + 1.0 https://www.nginx.com/resources/wiki/
Microsoft IIS[6] 7 7 https://www.iis.net

Joomla! 1.5 İçin Gereksinimler - destek 31 Aralık 2012 tarihinde sona erdi

Yazılım Önerilen Minumum Daha fazla bilgi
PHP[4] 5.3 4.3.10 https://secure.php.net
Desteklenen Veritabanları:
MySQL 4.1.x + 3.23 https://www.mysql.com
Desteklenen Web Sunucuları:
Apache[3]
(with mod_mysql, mod_xml, and mod_zlib)
2.0 + 1.3 https://www.apache.org
Microsoft IIS[6] 7 6 https://www.iis.net

Joomla! 1.0 İçin Gereksinimler - 22 Temmuz 2009'da destek sona erdi

Yazılım Önerilen Minumum Daha fazla bilgi
PHP[4] 5.3 4.2 https://secure.php.net
Desteklenen Veritabanları:
MySQL 4.1.x + 3.23 https://www.mysql.com
Desteklenen Web Sunucuları:
Apache[3]
(with mod_mysql, mod_xml, and mod_zlib)
2.x + 1.3 https://www.apache.org
Microsoft IIS[6] 7 6 https://www.iis.net

Dipnotlar

[1] Joomla! 3.0'dan 3.2'ye kadar olan sürümler için PHP 5.3.1 gereklidir. Joomla! 3.3'de minumum PHP 5.3.10'a yükseltilmelidir. Joomla! 3.5 ve sonrası sürümler PHP 7 ile uyumludur.

[2] Joomla! 3.5'de, MySQL `utf8mb4` karakter kümesi desteği eklendi ve destekleyen sunucular tarafından varsayılan olarak kullanılır

[3] SEO URL'lerini kullanmak için, Apache mod_rewrite uzantısının yüklü olması gerekir.

[4] PHP 4.3.9, 4.4.2 veya 5.0.4 kullanmayın. Bu sürümlerin kurulumda bazı hatalar verdiği biliniyor. PHP 4.4 için Zend Optimizer 2.5.10'da da ciddi hatalar var ve sunucu firmanızdan daha yeni bir sürüme geçiş yapmalarını istemelisiniz. Joomla! 1.5.15 ve daha sonraki sürümler PHP 5.3 ile uyumludur. OpenID kitaplığının PHP 5.3 ile uyumlu olmadığını unutmayın.

[[5] 2.5 sürümü için Microsoft SQL Server desteği eklendi; 1.6 ve 1.7'nin bu desteği yok.

[6] Microsoft IIS için (kurulumunuza bağlı olarak) aşağıdakilere ihtiyacınız olabilir:

Microsoft IIS kullanımı hakkında daha fazla yardım için Joomla! IIS forumunu ziyaret edin.

Yapılandırma Seçenekleri

Yerel bir bilgisayara yükleme yapıyorsanız, tek tek kurulumlardan daha hızlı kurulum yapmanıza yardımcı olacak birkaç paket bulunmaktadır:

  • LAMP (Linux) - Çoğu Linux dağıtımı önceden yapılandırılmış bir LAMP sunucusuyla birlikte gelmektedir.
  • WAMP (Windows) - Daha fazla bilgi için WampServer ana sayfası'nı ziyaret edin
  • MAMP (Apple OS) - Daha fazla bilgi için MAMP ana sayfası'nı ziyaret edin
  • XAMPP (Çoklu-Platform) - Canlı siteler için değildir. Daha fazla bilgi için XAMPP ana sayfası'nı ziyaret edin

Diğer seçeneklere ihtiyacınız varsa kurulum forumlarını ziyaret etmenizi veya isteğe bağlı teknik gereksinimler listemizi kontrol etmenizi öneririz.