Alla rekommenderade versioner är baserade på den senaste versionen av varje serie.

Krav för programvara som underhålls

Krav för Joomla! 3.x

Programvara Rekommenderad Minsta Mer Information
PHP[1] 7.1 + 5.3.10 (Magic Quotes GPC, MB String Overload = off)
(Zlib Compression Support, XML Support, INI Parser Support, JSON Support, Mcrypt Support, MB Language = Standard)
Databaser som stöds
MySQL[2] 5.5.3 + 5.1 (Stöd för InnoDB krävs)
SQL Server 10.50.1600.1 + 10.50.1600.1 https://www.microsoft.com/sql
PostgreSQL 9.1 + 8.3.18 https://www.postgresql.org/
Webbservrar som stöds
Apache[3] 2.4 + 2.0 (med mod_mysql, mod_xml, och mod_zlib)
Nginx 1.8 + 1.0 https://www.nginx.com/resources/wiki/
Microsoft IIS[6] 7 7 https://www.iis.net
Se https://docs.joomla.org/Joomla_Browser_Support för en lista med webbläsare som stöds i Joomla 3.x.

Krav för programvara som inte längre underhålls

Krav för Joomla! 1.6, 1.7, och 2.5

Stöd för denna version av Joomla! upphörde 31 december 2014
Programvara Rekommenderad Minsta Mer Information
PHP 5.6 5.2.4 https://secure.php.net
Databaser som stöds
MySQL 5.0.4 + 5.0.4 https://www.mysql.com
SQL Server[5] 10.50.1600.1 + 10.50.1600.1 https://www.microsoft.com/sql
Webbservrar som stöds
Apache[3] 2.2 + 2.0 (med mod_mysql, mod_xml, och mod_zlib)
Nginx 1.1 + 1.0 https://www.nginx.com/resources/wiki/
Microsoft IIS[6] 7 7 https://www.iis.net

Krav för Joomla! 1.5

Stöd för denna version av Joomla! upphörde 31 december 2012
Programvara Rekommenderad Minsta Mer Information
PHP[4] 5.3 4.3.10 https://secure.php.net
Databaser som stöds
MySQL 4.1.x + 3.23 https://www.mysql.com
Webbservrar som stöds
Apache[3] 2.0 + 1.3 (med mod_mysql, mod_xml, och mod_zlib)
Microsoft IIS[6] 7 6 https://www.iis.net

Krav för Joomla! 1.0

Stöd för denna version av Joomla! upphörde 22 juli 2009
Programvara Rekommenderad Minsta Mer Information
PHP[4] 5.3 4.3.10 https://secure.php.net
Databaser som stöds
MySQL 4.1.x + 3.23 https://www.mysql.com
Webbservrar som stöds
Apache[3] 2.0 + 1.3 (med mod_mysql, mod_xml, och mod_zlib)
Microsoft IIS[6] 7 6 https://www.iis.net

Fotnoter

[1] PHP 5.3.1 krävs för versioner 3.0 till 3.2. För 3.3 höjs lägsta krav till PHP 5.3.10. Joomla! version 3.5 och senare är kompatibla med PHP 7.

[2] Från och med Joomla! 3.5, har stöd för MySQL: s 'utf8mb4' teckenuppsättning lagts till och används som standard av servrar som stöder det.

[3] För att kunna använda SEO URL: er, behöver du ha tillägget Apache mod_rewrite installerat.

[4] Använd inte PHP 4.3.9, 4.4.2 eller 5.0.4. Dessa versioner har kända buggar som kommer att störa installationen. Zend Optimizer 2.5.10 för PHP 4.4 har också allvarliga fel och du bör be ditt webbhotell att uppgradera till en nyare version. Joomla! versioner 1.5.15 och senare är kompatibla med PHP 5.3. Observera att OpenID biblioteket inte är kompatibel med PHP 5.3.

[5] Stöd för Microsoft SQL Server har lagts till för utgåva 2.5. Utgåvorna 1.6 och 1.7 har inte detta stöd.

[6] För Microsoft IIS (beroende på dina inställningar) kan du behöva följande:

För ytterligare hjälp med hjälp av Microsoft IIS, besök Joomla! IIS forum.

Konfigurationsalternativ

Om du installerar på en lokal dator, finns det ett antal paket som hjälper dig installera snabbare än en individuell installation:

  • LAMPA (Linux) - de flesta Linux-distributioner har en förkonfigurerad LAMP-server.
  • WAMP (Windows) - för mer information, besök WampServers hemsida
  • MAMP (Apple OS) - för mer information, besök hemsidan för MAMP
  • XAMPP (flera plattformar) - inte för webbplatser som ligger Live. För mer information, besök hemsidan för XAMPP

Om du behöver andra alternativ, rekommenderar vi att besöka vår installationsforum för mer information eller kolla in vår lista över valfria tekniska krav.