Todas las versiones recomendadas se basan en la última versión de cada serie.

Requisitos para las versiones soportadas

Requisitos para Joomla! 3.x

Software Recomendado Mínimo Más información
PHP[1]
(Magic Quotes GPC off)
5.6 or 7.0 + 5.3.10 https://secure.php.net
Bases de datos soportadas:
MySQL[2]
(requiere soporte para InnoDB)
5.5.3 + 5.1 https://www.mysql.com
SQL Server 10.50.1600.1 + 10.50.1600.1 https://www.microsoft.com/sql
PostgreSQL 9.1 + 8.3.18 https://www.postgresql.org/
Servidores web soportados:
Apache[3]
(con los módulos mod_mysql, mod_xml, y mod_zlib)
2.4 + 2.0 https://www.apache.org
Nginx 1.8 + 1.0 https://www.nginx.com/resources/wiki/
Microsoft IIS[6] 7 7 https://www.iis.net

Requisitos para las versiones no soportadas

Requisitos para Joomla! 1.6, 1.7 y 2.5 - El soporte acabó el 31 de diciembre de 2014

Software Recomendado Mínimo Más información
PHP 5.6 5.2.4 https://secure.php.net
Bases de datos soportadas:
MySQL 5.0.4 + 5.0.4 https://www.mysql.com
SQL Server[5] 10.50.1600.1 + 10.50.1600.1 https://www.microsoft.com/sql
Servidores web soportados:
Apache[3]
(con los módulos mod_mysql, mod_xml, y mod_zlib)
2.2 + 2.0 https://www.apache.org
Nginx 1.1 + 1.0 https://www.nginx.com/resources/wiki/
Microsoft IIS[6] 7 7 https://www.iis.net

Requisitos para Joomla! 1.5 - El soporte acabó el 31 de diciembre de 2012

Software Recomendado Mínimo Más información
PHP[4] 5.3 4.3.10 https://secure.php.net
Bases de datos soportadas:
MySQL 4.1.x + 3.23 https://www.mysql.com
Servidores web soportados:
Apache[3]
(con los módulos mod_mysql, mod_xml, y mod_zlib)
2.0 + 1.3 https://www.apache.org
Microsoft IIS[6] 7 6 https://www.iis.net

Requisitos para Joomla! 1.0 - El soporte acabó el 22 de julio de 2009

Software Recomendado Mínimo Más información
PHP[4] 5.3 4.2 https://secure.php.net
Bases de datos soportadas:
MySQL 4.1.x + 3.23 https://www.mysql.com
Servidores web soportados:
Apache[3]
(con los módulos mod_mysql, mod_xml, y mod_zlib)
2.x + 1.3 https://www.apache.org
Microsoft IIS[6] 7 6 https://www.iis.net

Notas al pie

[1] PHP 5.3.1 es necesario para las versiones desde la 3.0 a la 3.2. En la versión 3.3, la versión mínima se eleva a PHP 5.3.10. Las versiones de Joomla! y posteriores son compatibles con PHP 7.

[2] a partir de Joomla! 3.5, se añade soporte para el conjunto de caracteres de MySQL 'utf8mb4' y es utilizado por defecto en los servidores que lo soportan

[3] en orden a usar URLs amigables, necesita tener instalada la extensión mod_rewrite de Apache.

[4] No utilice PHP 4.3.9, 4.4.2 o 5.0.4. Estas versiones tienen fallos conocidos interfieren con la instalación. Zend Optimizer 2.5.10 para PHP 4.4 también tiene graves errores y debe pedirle a su proveedor de alojamiento que actualice a una versión más reciente. Joomla! 1.5.15 y las versiones posteriores son compatibles con PHP 5.3. Tenga en cuenta que la librería OpenID no es compatible con PHP 5.3.

[5] El soporte para Microsoft SQL Server fue añadido en la versión 2.5; las versiones 1.6 y 1.7 no tienen soporte.

[6] Para Microsoft IIS (dependiendo su configuración) puede necesitar lo siguiente:

Para obenter asistencia si está usando Microsoft IIS, visite el foro de Joomla! IIS.

Opciones de configuración

Si está instalando en un ordenador local, hay unos cuantos paquetes que le ayudarán a comenzar más rápidamente que con instalaciones individuales:

  • LAMP (Linux) - La mayoría de las distribuciones Linux vienen con un servidor LAMP preconfigurado.
  • WAMP (Windows) - Para más inforamción, visite la página Web de WampServer
  • MAMP (Apple OS) - Para más información, visite la página web de MAMP
  • XAMPP (Multi plataforma) - No lo use para sitios en producción. Para más información visite la página de XAMPP

Si necesitas otras opciones, te recomendamos visitar nuestros foros de instalación para más información o comprobar la lista de requisitos técnicos opcionales.