Visas rekomendētās versijas ir balstītas uz pēdējās izlaistās versijas katrā kārtā.

Atbalstītās programmatūras prasības

Joomla! 3.x prasības

Programmatūra Ieteicamās Minimālās Vairāk informācijas
PHP[1]
(Magic Quotes GPC off)
5.6 or 7.0 + 5.3.10 https://secure.php.net
Atbalstītās datu bāzes:
MySQL[2]
(nepieciešams InnoDB atbalsts)
5.5.3 + 5.1 https://www.mysql.com
SQL Server 10.50.1600.1 + 10.50.1600.1 https://www.microsoft.com/sql
PostgreSQL 9.1 + 8.3.18 https://www.postgresql.org/
Atbalstītie Web serveri:
Apache[3]
(jāiekļauj mod_mysql, mod_xml, un mod_zlib)
2.4 + 2.0 https://www.apache.org
Nginx 1.8 + 1.0 https://www.nginx.com/resources/wiki/
Microsoft IIS[6] 7 7 https://www.iis.net

Neatbalstītas programmatūras prasības

Joomla! 1.6, 1.7, & 2.5 prasības - Atbalsts pārtraukts 2014. gada 31. decembrī

Programmatūra Ieteicamās Minimālās Vairāk informācijas
PHP 5.6 5.2.4 https://secure.php.net
Atbalstītās datu bāzes:
MySQL 5.0.4 + 5.0.4 https://www.mysql.com
SQL Server[5] 10.50.1600.1 + 10.50.1600.1 https://www.microsoft.com/sql
Atbalstītie Web serveri:
Apache[3]
(jāiekļauj mod_mysql, mod_xml, un mod_zlib)
2.2 + 2.0 https://www.apache.org
Nginx 1.1 + 1.0 https://www.nginx.com/resources/wiki/
Microsoft IIS[6] 7 7 https://www.iis.net

Joomla! 1.5 prasības - Atbalsts pārtraukts 2012. gada 31. decembrī

Programmatūra Ieteicamās Minimālās Vairāk informācijas
PHP[4] 5.3 4.3.10 https://secure.php.net
Atbalstītās datu bāzes:
MySQL 4.1.x + 3.23 https://www.mysql.com
Atbalstītie Web serveri:
Apache[3]
(jāiekļauj mod_mysql, mod_xml, un mod_zlib)
2.0 + 1.3 https://www.apache.org
Microsoft IIS[6] 7 6 https://www.iis.net

Joomla! 1.0 prasības - Atbalsts pārtraukts 2009. gada 22. jūlijā

Programmatūra Ieteicamās Minimālās Vairāk informācijas
PHP[4] 5.3 4.2 https://secure.php.net
Atbalstītās datu bāzes:
MySQL 4.1.x + 3.23 https://www.mysql.com
Atbalstītie Web serveri:
Apache[3]
(jāiekļauj mod_mysql, mod_xml, un mod_zlib)
2.x + 1.3 https://www.apache.org
Microsoft IIS[6] 7 6 https://www.iis.net

Piezīmes

[1] PHP 5.3.1 nepieciešams versijām no 3.0 līdz 3.2. Versijai 3.3, minimālais atbalsts PHP 5.3.10. Joomla! versijas 3.5 un vēlākas ir savietojamas ar PHP 7.

[2] Sākot ar Joomla! 3.5, MySQL ir pievienots atbalsts `utf8mb4` kodējumam un tiek lietots kā noklusētais uz serveriem, ja tas tiek atbalstīts

[3] Lai lietotu SEO saites ir jābūt instalētam Apache mod_rewrite paplašinājumam.

[4] Nelietojiet PHP 4.3.9, 4.4.2 vai 5.0.4. Šīm versijām ir kļūda kas iespaido instalāciju. Zend Optimizer 2.5.10 priekš PHP 4.4 satur kļūdas un to jāatjauno uz jaunāku versiju. Joomla! versijas 1.5.15 un vēlākas ir savietojamas ar PHP 5.3. Atcerieties ka OpenID bibliotēka nav savietojama ar PHP 5.3.

[5] Microsoft SQL Server atbalsts tika pievienots 2.5 versijā; 1.6 un 1.7 netiek atbalstīts.

[6] Microsoft IIS (atkarīgs no iestatījumiem) serverim nepieciešams:

Microsoft IIS lietotājiem, apmeklējiet Joomla! IIS forumu.

Konfigurācijas opcijas

Instalējot uz lokālā datora ir pieejamas pakotnes ar kuru palīdzību var Joomla! uzstādīt ātrāk kā instalējot atsevišķi:

  • LAMP (Linux) - Lielākā daļa Linux distributīvu ir ar jau uzstādītu LAMP serveri.
  • WAMP (Windows) - Vairāk informācijas WampServer lapā
  • MAMP (Apple OS) - Vairāk informācijas MAMP lapā
  • XAMPP (Multiplatformām) - Vairāk informācijas XAMPP lapā

Ja nepieciešamas papildus funkcijas, iesakām apmeklēt instalācijas forumus.