Alle anbefalte versjoner er basert på den siste utgivelsen i hver serie.

Krav for støttede versjoner

Krav for Joomla! 3.x

Programvare Anbefalte Minimum Mer informasjon
PHP[1] 7.1 + 5.3.10 (Magic Quotes GPC, MB String Overload = off)
(Zlib Compression Support, XML Support, INI Parser Support, JSON Support, Mcrypt Support, MB Language = Default)
Støttede databaser
MySQL[2] 5.5.3 + 5.1 (InnoDB støtte er påkrevd)
SQL Server 10.50.1600.1 + 10.50.1600.1 https://www.microsoft.com/sql
PostgreSQL 9.1 + 8.3.18 https://www.postgresql.org/
Støttede webservere
Apache[3] 2.4 + 2.0 (med mod_mysql, mod_xml, og mod_zlib)
Nginx 1.8 + 1.0 https://www.nginx.com/resources/wiki/
Microsoft IIS[6] 7 7 https://www.iis.net
Vennligst se https://docs.joomla.org/Joomla_Browser_Support for en liste over nettlesere som er støttet av Joomla 3.x.

Krav for ustøttede versjoner

Krav for Joomla! 1.6, 1.7, & 2.5

Støtte for denne versjonen av Joomla! opphørte den 31. desember 2014
Programvare Anbefalte Minimum Mer informasjon
PHP 5.6 5.2.4 https://secure.php.net
Støttede databaser
MySQL 5.0.4 + 5.0.4 https://www.mysql.com
SQL Server[5] 10.50.1600.1 + 10.50.1600.1 https://www.microsoft.com/sql
Støttede webservere
Apache[3] 2.2 + 2.0 (med mod_mysql, mod_xml, og mod_zlib)
Nginx 1.1 + 1.0 https://www.nginx.com/resources/wiki/
Microsoft IIS[6] 7 7 https://www.iis.net

Krav for Joomla! 1.5

Støtte for denne versjonen av Joomla! opphørte den 31. desember 2012
Programvare Anbefalte Minimum Mer informasjon
PHP[4] 5.3 4.3.10 https://secure.php.net
Støttede databaser
MySQL 4.1.x + 3.23 https://www.mysql.com
Støttede webservere
Apache[3] 2.0 + 1.3 (med mod_mysql, mod_xml, og mod_zlib)
Microsoft IIS[6] 7 6 https://www.iis.net

Krav for Joomla! 1.0

Støtte for denne versjonen av Joomla! opphørte den 22. juli 2009
Programvare Anbefalte Minimum Mer informasjon
PHP[4] 5.3 4.3.10 https://secure.php.net
Støttede databaser
MySQL 4.1.x + 3.23 https://www.mysql.com
Støttede webservere
Apache[3] 2.0 + 1.3 (med mod_mysql, mod_xml, og mod_zlib)
Microsoft IIS[6] 7 6 https://www.iis.net

Fotnoter

[1] PHP 5.3.1 er påkrevd for versjoner 3.0 til 3.2. På 3.3, er minimum versjon økt til PHP 5.3.10. Joomla! versjoner 3.5 og senere er kompatible med PHP 7.

[2] Fra Joomla! 3.5, er støtte for MySQL sitt `utf8mb4` tegnsett lagt til. Dette brukes som standard på servere som støtter det.

[3] For å bruke SEO URLer, må du ha Apache mod_rewrite utvidelsen installert.

[4] Ikke bruk PHP 4.3.9, 4.4.2 eller 5.0.4. Disse utgivelsene har kjente feil som vil forstyrre installasjonen. Zend Optimizer 2.5.10 til PHP 4.4 inneholder alvorlige feil. Vennligst spør din leverandør om å oppgradere til en nyere versjon. Joomla! versjoner 1.5.15 og senere er kompatible med PHP 5.3. Merk at OpenID biblioteket ikke er kompatibelt med PHP 5.3.

[5] Støtte for Microsoft SQL Server ble lagt til for 2.5 serien; 1.6 og 1.7 støtter ikke dette.

[6] For Microsoft IIS (avhengig av oppsettet) trenger du kanskje følgende:

For mer assistanse vedrørende bruk av Microsoft IIS, besøk Joomla! IIS forumet.

Konfigurasjonsinnstillinger

Hvis du installerer Joomla! på en lokal datamaskin, finnes det en rekke pakker som vil hjelpe deg i gang raskere enn enkle installasjoner:

  • LAMP (Linux) - De fleste Linux distribusjoner kommer en en prekonfigurert LAMP server.
  • WAMP (Windows) - For mer informasjon, gå til nettsiden til WampServer
  • MAMP (Apple OS) - For mer informasjon, besøk MAMP
  • XAMPP (multi-plattform) - Ikke for publiserte nettsider. For mer informasjon, gå til nettsiden til XAMPP

Hvis du trenger andre alternativer, anbefaler vi å besøke våre installasjon forum for mer informasjon eller sjekke ut vår liste over valgfrie tekniske krav.