Toate versiunile recomandate se bazează pe ultima versiune din fiecare serie.

Cerințele pentru software-ul suportat

Cerințele pentru Joomla! 3.x

Software Recomandat Minim Mai multe informaţii
PHP[1]
(Magic Quotes GPC off)
5.6 or 7.0 + 5.3.10 https://secure.php.net
Baze de date suportate:
MySQL[2]
(suport InnoDB necesar)
5.5.3 + 5.1 https://www.mysql.com
SQL Server 10.50.1600.1 + 10.50.1600.1 https://www.microsoft.com/sql
PostgreSQL 9.1 + 8.3.18 https://www.postgresql.org/
Servere Web acceptate:
Apache[3]
(cu mod_mysql, mod_xml, şi mod_zlib)
2.4 + 2.0 https://www.apache.org
Nginx 1.8 + 1.0 https://www.nginx.com/resources/wiki/
Microsoft IIS[6] 7 7 https://www.iis.net

Cerințele pentru software-ul nesuportat

Cerințele pentru Joomla! 1.6, 1.7, si 2.5 - suportul s-a terminat pe 31 decembrie 2014

Software Recomandat Minim Mai multe informaţii
PHP 5.6 5.2.4 https://secure.php.net
Baze de date suportate:
MySQL 5.0.4 + 5.0.4 https://www.mysql.com
SQL Server[5] 10.50.1600.1 + 10.50.1600.1 https://www.microsoft.com/sql
Servere Web acceptate:
Apache[3]
(cu mod_mysql, mod_xml, şi mod_zlib)
2.2 + 2.0 https://www.apache.org
Nginx 1.1 + 1.0 https://www.nginx.com/resources/wiki/
Microsoft IIS[6] 7 7 https://www.iis.net

Cerințele pentru Joomla! 1.5 - suportul s-a terminat pe 31 decembrie 2012

Software Recomandat Minim Mai multe informaţii
PHP[4] 5.3 4.3.10 https://secure.php.net
Baze de date suportate:
MySQL 4.1.x + 3.23 https://www.mysql.com
Servere Web acceptate:
Apache[3]
(cu mod_mysql, mod_xml, şi mod_zlib)
2.0 + 1.3 https://www.apache.org
Microsoft IIS[6] 7 6 https://www.iis.net

Cerințele pentru Joomla! 1.0 - suportul s-a terminat pe 22 julie 2009

Software Recomandat Minim Mai multe informaţii
PHP[4] 5.3 4.2 https://secure.php.net
Baze de date suportate:
MySQL 4.1.x + 3.23 https://www.mysql.com
Servere Web acceptate:
Apache[3]
(cu mod_mysql, mod_xml, şi mod_zlib)
2.x + 1.3 https://www.apache.org
Microsoft IIS[6] 7 6 https://www.iis.net

Note de subsol

[1] PHP 5.3.1 este necesară pentru versiunile 3.0 -3.2. La 3.3, valoarea minimă este ridicată la PHP 5.3.10. Versiunile Joomla! 3.5 şi mai noi sunt compatibile cu PHP 7.

[2] începând cu Joomla! 3.5, suportul pentru setul de caractere MySQL "utf8mb4" este adăugat şi utilizate în mod implicit pe serverele care îl suportă

[3] Pentru a se putea folosi URL-uri SEO, serverul va trebui să aibă extensia Apache mod_rewrite instalat.

[4] A nu se folosi PHP 4.3.9, 4.4.2 sau 5.0.4. Aceste versiuni au bug-uri cunoscute care vor interfera cu instalarea. Zend Optimizer 2.5.10 pentru PHP 4.4 are bug-uri grave şi v-a trebui să solicitați de la compania de găzduire să facă upgrade la o versiune mai nouă. Joomla! versiunile 1.5.15 şi mai târziu sunt compatibile cu PHP 5.3. Reţineţi că biblioteca OpenID nu este compatibilă cu PHP 5.3.

[5] Suportul pentru Microsoft SQL Server a fost adăugată pentru versiunea 2.5; 1.6 și 1.7 nu au acest sprijin.

[6] pentru Microsoft IIS (în funcţie de setări) s-ar putea să aveți nevoie de următoarele:

Pentru asistenţă suplimentară în utilizarea Microsoft IIS, vizitaţi forumul Joomla! IIS .

Opțiuni de Configurare

În cazul în care instalați pe un computer local, există un număr de pachete, care vă vor ajuta să porniți mai repede și mai simplu decât instalând componente individuale:

  • LAMP (Linux) - majoritatea distribuţiilor Linux vin cu un LAMP server pre-configurat.
  • WAMP (Windows) - pentru mai multe informaţii, vizitaţi pagina de pornire WampServer
  • MAMP (Apple OS) - pentru mai multe informaţii, vizitaţi pagina de pornire MAMP
  • XAMPP (multi-platformă) - nu este recomandat pentru site-uri live. Pentru mai multe informaţii, vizitaţi pagina de pornire XAMPP

Dacă aveţi nevoie de alte opţiuni, vă recomandăm vizitarea forumurilor de instalare pentru mai multe informaţii sau verificați lista noastră de cerințe tehnice opţionale.