Tutte le versioni consigliate sono basate sull'ultima versione rilasciata di ciascuna serie.

Requisiti per il Software supportato

Requisiti per Joomla! 3.x

Software Consigliato Minimi Ulteriori Informazioni
PHP[1] 7.1 + 5.3.10 (Magic Quotes GPC, MB String Overload = off)
(Zlib Compression Support, XML Support, INI Parser Support, JSON Support, Mcrypt Support, MB Language = Default)
Database supportati
MySQL[2] 5.5.3 + 5.1 (supporto a InnoDB richiesto)
SQL Server 10.50.1600.1 + 10.50.1600.1 https://www.microsoft.com/sql
PostgreSQL 9.1 + 8.3.18 https://www.postgresql.org/
Server Web supportati
Apache[3] 2.4 + 2.0 (con mod_mysql, mod_xml, e mod_zlib)
Nginx 1.8 + 1.0 https://www.nginx.com/resources/wiki/
Microsoft IIS[6] 7 7 https://www.iis.net
Controlla https://docs.joomla.org/Joomla_Browser_Support per una lista dei browser supportati da Joomla 3.x.

Requisiti per il Software non supportato

Requisiti per Joomla! 1.6, 1.7, & 2.5

Supporto per questa versione di Joomla! terminato il 31 Dicembre 2014
Software Consigliato Minimi Ulteriori Informazioni
PHP 5.6 5.2.4 https://secure.php.net
Database supportati
MySQL 5.0.4 + 5.0.4 https://www.mysql.com
SQL Server[5] 10.50.1600.1 + 10.50.1600.1 https://www.microsoft.com/sql
Server Web supportati
Apache[3] 2.2 + 2.0 (con mod_mysql, mod_xml, e mod_zlib)
Nginx 1.1 + 1.0 https://www.nginx.com/resources/wiki/
Microsoft IIS[6] 7 7 https://www.iis.net

Requisiti per Joomla! 1.5

Supporto per questa versione di Joomla! terminato il 31 Dicembre 2012
Software Consigliato Minimi Ulteriori Informazioni
PHP[4] 5.3 4.3.10 https://secure.php.net
Database supportati
MySQL 4.1.x + 3.23 https://www.mysql.com
Server Web supportati
Apache[3] 2.0 + 1.3 (con mod_mysql, mod_xml, e mod_zlib)
Microsoft IIS[6] 7 6 https://www.iis.net

Requisiti per Joomla! 1.0

Supporto per questa versione di Joomla! terminato il 22 Luglio 2009
Software Consigliato Minimi Ulteriori Informazioni
PHP[4] 5.3 4.3.10 https://secure.php.net
Database supportati
MySQL 4.1.x + 3.23 https://www.mysql.com
Server Web supportati
Apache[3] 2.0 + 1.3 (con mod_mysql, mod_xml, e mod_zlib)
Microsoft IIS[6] 7 6 https://www.iis.net

Note a piè pagina

[1] PHP 5.3.1 è necessario per le versioni 3.0 fino alla 3.2. Dalla versione 3.3 il minimo è stato elevato a PHP 5.3.10. Le versioni di Joomla! 3.5 e successive sono compatibli con PHP 7.

[2] A partire da Joomla! 3.5, il supporto per il set di caratteri `utf8mb4`di MySQL è stato aggiunto ed è utilizzato di default sui server che lo supportano.

[3] Per utilizzare gli URL SEO, è necessario che l'estensione mod_rewrite di Apache sia installata.

[4] Non utilizzare PHP 4.3.9, 4.4.2 o 5.0.4. Queste versioni contengono dei bug noti che interferiscono con l'installazione. Zend Optimizer 2.5.10 per PHP 4.4 è affetto da seri bug e dovresti chiedere al tuo hosting di aggiornarlo ad una nuova versione. Le versioni di Joomla! 1.5.15 e successive sono compatibili con PHP 5.3. Nota che la libreria OpenID non è compatibile con PHP 5.3.

[5] Il supporto per Microsoft SQL Server è stato aggiunto nella versione 2.5; le versioni 1.6 e 1.7 non lo supportano.

[6] Per Microsoft IIS (a seconda della configurazione) potrebbe essere necessario avere quanto segue:

Per ulteriore assistenza per l'utilizzo di Microsoft IIS, visitare il Forum Joomla! IIS.

Opzioni di configurazione

In caso di installazione su un computer locale, ci sono una serie di pacchetti che ti aiuteranno ad ottenere un'impostazione più rapida rispetto alle singole installazioni:

  • LAMP (Linux) - La maggior parte delle distribuzioni Linux sono dotate di un server LAMP pre-configurato.
  • WAMP (Windows) - Per ulteriori informazioni, visita la homepage di WampServer
  • MAMP (Apple OS) - Per ulteriori informazioni, visita la homepage di MAMP
  • XAMPP (Multi-piattaforma) - Da non usare su siti online. Per ulteriori informazioni, visita la homepage di XAMPP

Se hai bisogno di altre opzioni, ti consigliamo di visitare il nostro Forum installazioni per ulteriori informazioni oppure controlla la lista dei requisiti tecnici facoltativi.