Semua versi rekomendasi berdasarkan versi rilis terakhir masing-masing seri.

Persyaratan Perangkat Lunak Yang Didukung

Persyaratan untuk Joomla! 3.x

Software Direkomendasikan Minimal Informasi selengkapnya
PHP[1] 7.1 + 5.3.10 (Magic Quotes GPC, MB String Overload = off)
(Zlib Compression Support, XML Support, INI Parser Support, JSON Support, Mcrypt Support, MB Language = Default)
Database Yang Didukung
MySQL[2] 5.5.3 + 5.1 (wajib mendukung InnoDB)
SQL Server 10.50.1600.1 + 10.50.1600.1 https://www.microsoft.com/sql
PostgreSQL 9.1 + 8.3.18 https://www.postgresql.org/
Server Web Yang Didukung
Apache[3] 2.4 + 2.0 (dengan mod_mysql, mod_xml, dan mod_zlib)
Nginx 1.8 + 1.0 https://www.nginx.com/resources/wiki/
Microsoft IIS[6] 7 7 https://www.iis.net
Lihat https://docs.joomla.org/Joomla_Browser_Support untuk daftar browser yang didukung di Joomla 3.x.

Persyaratan untuk Software Yang Tidak Didukung

Persyaratan untuk Joomla! 1.6, 1.7, & 2.5

Dukungan untuk Joomla! versi ini telah berakhir pada 31 Desember 2014
Software Direkomendasikan Minimal Informasi selengkapnya
PHP 5.6 5.2.4 https://secure.php.net
Database Yang Didukung
MySQL 5.0.4 + 5.0.4 https://www.mysql.com
SQL Server[5] 10.50.1600.1 + 10.50.1600.1 https://www.microsoft.com/sql
Server Web Yang Didukung
Apache[3] 2.2 + 2.0 (dengan mod_mysql, mod_xml, dan mod_zlib)
Nginx 1.1 + 1.0 https://www.nginx.com/resources/wiki/
Microsoft IIS[6] 7 7 https://www.iis.net

Persyaratan untuk Joomla! 1.5

Dukungan untuk Joomla! versi ini telah berakhir pada 31 Desember 2012
Software Direkomendasikan Minimal Informasi selengkapnya
PHP[4] 5.3 4.3.10 https://secure.php.net
Database Yang Didukung
MySQL 4.1.x + 3.23 https://www.mysql.com
Server Web Yang Didukung
Apache[3] 2.0 + 1.3 (dengan mod_mysql, mod_xml, dan mod_zlib)
Microsoft IIS[6] 7 6 https://www.iis.net

Persyaratan untuk Joomla! 1.0

Dukungan untuk Joomla! versi ini telah berakhir pada 22 Juli 2009
Software Direkomendasikan Minimal Informasi selengkapnya
PHP[4] 5.3 4.3.10 https://secure.php.net
Database Yang Didukung
MySQL 4.1.x + 3.23 https://www.mysql.com
Server Web Yang Didukung
Apache[3] 2.0 + 1.3 (dengan mod_mysql, mod_xml, dan mod_zlib)
Microsoft IIS[6] 7 6 https://www.iis.net

Catatan

[1] PHP 5.3.1 wajib untuk versi 3.0 sampai 3.2. Pada 3.3, syarat minimalnya dinaikkan menjadi PHP 5.3.10. Joomla! versi 3.5 dan selanjutnya kompatibel dengan PHP 7.

[2] Untuk Joomla! 3.5, dukungan set karakter `utf8mb4` MySQL telah ditambahkan dan dipakai secara standar di server-server yang mendukungnya.

[3] Untuk dapat menggunakan URL SEO, Anda harus memiliki ekstensi mod_rewrite di Apache.

[4] Jangan gunakan PHP 4.3.9, 4.4.2 atau 5.0.4. Rilis ini diketahui memiliki bugs yang akan mengganggu instalasi. Zend Optimizer 2.5.10 untuk PHP 4.4 juga memiliki bugs yang cukup serius dan Anda harus meminta upgrade kepada hosting Anda. Joomla! versi 1.5.15 dan selanjutnya kompatibel dengan PHP 5.3. Mohon dicatat bahwa, pustaka OpenID tidak kompatibel dengan PHP 5.3.

[5] Dukungan untuk Microsoft SQL Server telah ditambahkan di rilis 2.5; 1.6 dan 1.7 tidak memiliki dukungan ini.

[6] Untuk Microsoft IIS (tergantung pengaturan Anda) mungkin Anda memerlukan hal-hal berikut:

Untuk bantuan Microsoft IIS, kunjungi forum IIS Joomla.

Opsi Konfigurasi

Bila menginstal di lokal komputer, ada beberapa paket yang dapat membantu pengaturan agar lebih ringkas dan cepat daripada menginstal satu-satu:

  • LAMP (Linux) - Rata-rata distro Linux hadir bersama pra-konfigurasi server LAMP.
  • WAMP (Windows) - Untuk informasi selengkapnya, kunjungi situs WampServer
  • MAMP (Apple OS) - Untuk informasi selengkapnya, kunjungi situs MAMP
  • XAMPP (Multi-platform) - Bukan untuk produksi. Untuk informasi selengkapnya, kunjungi situs XAMPP

Untuk pilihan lainnya, kunjungilah forum instalasi kami atau periksa daftar persyaratan teknis opsional kami.