Todas las versiones recomendadas se basan en la versión más reciente de cada serie.

Requisitos para las versiones soportadas

Requirements for Joomla! 3.x

Software Recomendado Mínimo Más información
PHP[1] 7.3 + 5.3.10 (Magic Quotes GPC, MB String Overload = off)
(Zlib Compression Support, XML Support, INI Parser Support, JSON Support, MB Language = Default)
Bases de datos soportadas
MySQL[2] 5.5.3 + 5.1 (requiere soporte para InnoDB)
SQL Server 10.50.1600.1 + 10.50.1600.1 https://www.microsoft.com/sql
PostgreSQL 9.1 + 8.3.18 https://www.postgresql.org/
Servidores web soportados
Apache[3] 2.4 + 2.0 (con los módulos mod_mysql, mod_xml, y mod_zlib)
Nginx 1.8 + 1.0 https://www.nginx.com/resources/wiki/
Microsoft IIS[6] 7 7 https://www.iis.net
Revisa https://docs.joomla.org/Joomla_Browser_Support para obtener una lista de navegadores soportados en Joomla 3.x.

Requisitos para las versiones obsoletas

Requirements for Joomla! 4.x

This version of Joomla has not been released yet so these versions should be considered preliminary
Software Recomendado Mínimo[7] Más información
PHP 7.4 7.2.5 https://www.php.net
Bases de datos soportadas
MySQL 5.6 + 5.6 https://www.mysql.com
PostgreSQL 11.0 + 11.0 (ext/pgsql support in PHP has been removed. Now uses the PostgreSQL PDO Driver)
Servidores web soportados
Apache[3] 2.4 + 2.4 (con los módulos mod_mysql, mod_xml, y mod_zlib)
Nginx 1.18 + 1.10 https://www.nginx.com/resources/wiki/
Microsoft IIS[6] 10 + 8 https://www.iis.net

Requisitos para Joomla! 1.6, 1.7 y 2.5

El soporte para esta versión de Joomla! terminó en 31 Diciembre 2014
Software Recomendado Mínimo Más información
PHP 5.6 5.2.4 https://www.php.net
Bases de datos soportadas
MySQL 5.0.4 + 5.0.4 https://www.mysql.com
SQL Server[5] 10.50.1600.1 + 10.50.1600.1 https://www.microsoft.com/sql
Servidores web soportados
Apache[3] 2.2 + 2.0 (con los módulos mod_mysql, mod_xml, y mod_zlib)
Nginx 1.1 + 1.0 https://www.nginx.com/resources/wiki/
Microsoft IIS[6] 7 7 https://www.iis.net

Requisitos para Joomla! 1.5

El soporte para esta versión de Joomla! terminó en 31 Diciembre 2012
Software Recomendado Mínimo Más información
PHP[4] 5.3 4.3.10 https://www.php.net
Bases de datos soportadas
MySQL 4.1.x + 3.23 https://www.mysql.com
Servidores web soportados
Apache[3] 2.0 + 1.3 (con los módulos mod_mysql, mod_xml, y mod_zlib)
Microsoft IIS[6] 7 6 https://www.iis.net

Requisitos para Joomla! 1.0

El soporte para esta versión de Joomla! terminó en 22 Julio 2009
Software Recomendado Mínimo Más información
PHP[4] 5.3 4.3.10 https://www.php.net
Bases de datos soportadas
MySQL 4.1.x + 3.23 https://www.mysql.com
Servidores web soportados
Apache[3] 2.0 + 1.3 (con los módulos mod_mysql, mod_xml, y mod_zlib)
Microsoft IIS[6] 7 6 https://www.iis.net

Referencias

[1] PHP 5.3.1 es necesario para las versiones desde la 3.0 a la 3.2. En la versión 3.3, la versión mínima es PHP 5.3.10. Las versiones de Joomla! 3.5 y posteriores son compatibles con PHP 7.

[2] A partir de Joomla! 3.5, se agrega soporte para el conjunto de caracteres de MySQL 'utf8mb4' y es utilizado por defecto en los servidores que lo soportan.

[3] Para poder utilizar URLs amigables, necesita tener instalada la extensión mod_rewrite de Apache.

[4] No utilices PHP 4.3.9, 4.4.2 o 5.0.4. Estas versiones tienen fallos conocidos que interfieren con la instalación. Zend Optimizer 2.5.10 para PHP 4.4 también tiene graves errores y debes pedirle a tu proveedor de hosting que actualice a una versión más reciente. Joomla! 1.5.15 y las versiones posteriores son compatibles con PHP 5.3. Ten en cuenta que la librería OpenID no es compatible con PHP 5.3.

[5] El soporte para Microsoft SQL Server fue agregado en la versión 2.5; las versiones 1.6 y 1.7 no lo soportan.

[6] Para Microsoft IIS (dependiendo de tu configuración) puedes necesitar lo siguiente:

Para obtener ayuda si estsá usando Microsoft IIS, visita el foro de Joomla! IIS.

[7] This is the minimum version which is guaranteed to work, older versions may work but are not supported.

Opciones de configuración

Si vas a instalar Joomla! en tu computador, hay unos instaladores que te ayudarán a organizar rápidamente tu servidor local, en vez de instalar cada requisito por aparte:

  • LAMP (Linux) - La mayoría de las distribuciones Linux vienen con un servidor LAMP preconfigurado.
  • WAMP (Windows) - Para más inforamción, visita la página web de WampServer
  • MAMP (Apple OS) - para más información, visita el sitio web de MAMP
  • XAMPP (Multiplataforma) - No lo utilices para sitios en producción. Para más información visita la página de XAMPP

Si necesitas otras opciones, te recomendamos visitar nuestros foros de instalación para más información o comprobar la lista de requisitos técnicos opcionales.