Все рекомендованные версии основаны на последней выпущенной версии каждой серии.

Требования для поддерживаемого программного обеспечения

Requirements for Joomla! 3.x

Программное обеспечение Рекомендованные Минимальные Дополнительная информация
PHP[1] 7.3 + 5.3.10 (Magic Quotes GPC, MB String Overload = off)
(поддержка Zlib Compression, поддержка XML, поддержка INI Parser, поддержка JSON, MB Language = Default)
Поддерживаемые базы данных
MySQL[2] 5.5.3 + 5.1 (требуется поддержка InnoDB)
SQL Server 10.50.1600.1 + 10.50.1600.1 https://www.microsoft.com/sql
PostgreSQL 9.1 + 8.3.18 https://www.postgresql.org/
Поддерживаемые веб-серверы
Apache[3] 2.4 + 2.0 (с mod_mysql, mod_xml и mod_zlib)
Nginx 1.8 + 1.0 https://www.nginx.com/resources/wiki/
Microsoft IIS[6] 7 7 https://www.iis.net
Список поддерживаемых в Joomla 3.x обозревателей вы можете посмотреть здесь https://docs.joomla.org/Joomla_Browser_Support.

Требования для неподдерживаемого программного обеспечения

Requirements for Joomla! 4.x

This version of Joomla has not been released yet so these versions should be considered preliminary
Программное обеспечение Рекомендованные Минимальные[7] Дополнительная информация
PHP 7.4 7.2.5 https://www.php.net
Поддерживаемые базы данных
MySQL 5.6 + 5.6 https://www.mysql.com
PostgreSQL 11.0 + 11.0 (ext/pgsql support in PHP has been removed. Now uses the PostgreSQL PDO Driver)
Поддерживаемые веб-серверы
Apache[3] 2.4 + 2.4 (с mod_mysql, mod_xml и mod_zlib)
Nginx 1.18 + 1.10 https://www.nginx.com/resources/wiki/
Microsoft IIS[6] 10 + 8 https://www.iis.net

Требования для Joomla! 1.6, 1.7, & 2.5

Поддержка этой версии Joomla! закончилась в 31 декабря 2014
Программное обеспечение Рекомендованные Минимальные Дополнительная информация
PHP 5.6 5.2.4 https://www.php.net
Поддерживаемые базы данных
MySQL 5.0.4 + 5.0.4 https://www.mysql.com
SQL Server[5] 10.50.1600.1 + 10.50.1600.1 https://www.microsoft.com/sql
Поддерживаемые веб-серверы
Apache[3] 2.2 + 2.0 (с mod_mysql, mod_xml и mod_zlib)
Nginx 1.1 + 1.0 https://www.nginx.com/resources/wiki/
Microsoft IIS[6] 7 7 https://www.iis.net

Требования для Joomla! 1.5

Поддержка этой версии Joomla! закончилась в 31 декабря 2012
Программное обеспечение Рекомендованные Минимальные Дополнительная информация
PHP[4] 5.3 4.3.10 https://www.php.net
Поддерживаемые базы данных
MySQL 4.1.x + 3.23 https://www.mysql.com
Поддерживаемые веб-серверы
Apache[3] 2.0 + 1.3 (с mod_mysql, mod_xml и mod_zlib)
Microsoft IIS[6] 7 6 https://www.iis.net

Требования для Joomla! 1.0

Поддержка этой версии Joomla! закончилась в 22 июля 2009
Программное обеспечение Рекомендованные Минимальные Дополнительная информация
PHP[4] 5.3 4.3.10 https://www.php.net
Поддерживаемые базы данных
MySQL 4.1.x + 3.23 https://www.mysql.com
Поддерживаемые веб-серверы
Apache[3] 2.0 + 1.3 (с mod_mysql, mod_xml и mod_zlib)
Microsoft IIS[6] 7 6 https://www.iis.net

Примечания

[1] PHP 5.3.1 требуется для версиий от 3.0 до 3.2. Для 3.3 минимальные требования подняты до PHP 5.3.10. Версии Joomla! 3.5 и выше совместимы с PHP 7.

[2] В Joomla! 3.5 для MySQL была добавлена поддержка кодировки`utf8mb4`, которая используется по умолчанию на серверах, её поддерживающих.

[3] Для использования SEO URL в Apache должно быть установлено расширение mod_rewrite.

[4] Не используйте PHP 4.3.9, 4.4.2 или 5.0.4. Эти релизы имеют известные ошибки, которые будут мешать установке. Zend Optimizer 2.5.10 для PHP 4.4 также имеет серьёзные ошибки, поэтому вы должны попросить вашего хостинг-провайдера обновить его до более новой версии. Joomla! версии 1.5.15 и выше совместимы с PHP 5.3. Учтите, что библиотека OpenID несовместима с PHP 5.3.

[5] Поддержка сервера Microsoft SQL была добавлена в релиз 2.5; 1.6 и 1.7 не имеют такой поддержки.

[6] Для Microsoft IIS (зависит от ваших настроек) вам может понадобиться следующее:

Для дальнейшей поддержки по использованию Microsoft IIS, посетите форум Joomla! IIS.

[7] This is the minimum version which is guaranteed to work, older versions may work but are not supported.

Параметры конфигурации

Для установки на локальный компьтер существуют пакеты, которые помогут вам быстро настроить нужное окружение:

Если вам необходимы другие варианты, мы рекомендуем посетить наш форум по установке для получения дополнительной информации или проверить наш список необязательных технических требований.