Todas as versões recomendadas são baseadas na versão mais recente de cada série.

Requisitos para Software Suportado

Requisitos para Joomla! 3.x

Software Recomendado Mínimo Mais Informações
PHP[1] 7.1 + 5.3.10 (Magic Quotes GPC, MB String Overload = off)
(Zlib Compression Support, XML Support, INI Parser Support, JSON Support, Mcrypt Support, MB Language = Default)
Bancos de Dados Suportados
MySQL[2] 5.5.3 + 5.1 (suporte InnoDB necessário)
SQL Server 10.50.1600.1 + 10.50.1600.1 https://www.microsoft.com/sql
PostgreSQL 9.1 + 8.3.18 https://www.postgresql.org/
Servidores Web Suportados
Apache[3] 2.4 + 2.0 (com mod_mysql, mod_xml e mod_zlib)
Nginx 1.8 + 1.0 https://www.nginx.com/resources/wiki/
Microsoft IIS[6] 7 7 https://www.iis.net
Por favor veja https://docs.joomla.org/Joomla_Browser_Support para obter uma lista de navegadores suportados no Joomla 3. x.

Requisitos para Software Não Suportado

Requisitos para Joomla! 1.6, 1.7 e 2.5

O suporte para esta versão do Joomla! terminou em 31 Dezembro 2014
Software Recomendado Mínimo Mais Informações
PHP 5.6 5.2.4 https://secure.php.net
Bancos de Dados Suportados
MySQL 5.0.4 + 5.0.4 https://www.mysql.com
SQL Server[5] 10.50.1600.1 + 10.50.1600.1 https://www.microsoft.com/sql
Servidores Web Suportados
Apache[3] 2.2 + 2.0 (com mod_mysql, mod_xml e mod_zlib)
Nginx 1.1 + 1.0 https://www.nginx.com/resources/wiki/
Microsoft IIS[6] 7 7 https://www.iis.net

Requisitos para Joomla! 1.5

O suporte para esta versão do Joomla! terminou em 31 Dezembro 2012
Software Recomendado Mínimo Mais Informações
PHP[4] 5.3 4.3.10 https://secure.php.net
Bancos de Dados Suportados
MySQL 4.1.x + 3.23 https://www.mysql.com
Servidores Web Suportados
Apache[3] 2.0 + 1.3 (com mod_mysql, mod_xml e mod_zlib)
Microsoft IIS[6] 7 6 https://www.iis.net

Requisitos para Joomla! 1.0

O suporte para esta versão do Joomla! terminou em 22 Julho 2009
Software Recomendado Mínimo Mais Informações
PHP[4] 5.3 4.3.10 https://secure.php.net
Bancos de Dados Suportados
MySQL 4.1.x + 3.23 https://www.mysql.com
Servidores Web Suportados
Apache[3] 2.0 + 1.3 (com mod_mysql, mod_xml e mod_zlib)
Microsoft IIS[6] 7 6 https://www.iis.net

Notas

[1] PHP 5.3.1 é necessário nas versões 3.0 a 3.2. Na 3.3, o mínimo passou para PHP 5.3.10. Joomla! versões 3.5 e posteriores são compatíveis com PHP 7.

[2] A partir do Joomla! 3.5, o suporte ao conjunto de caracteres `utf8mb4` do MySQL foi adicionado e é usado por padrão em servidores que o suportam.

[3] Para usar URLs SEO, é necessário ter a extensão mod_rewrite do Apache instalada.

[4] Não use PHP 4.3.9, 4.4.2 ou 5.0.4. Estas versões têm bugs conhecidos que interferem com a instalação. Zend Optimizer 2.5.10 para PHP 4.4 também tem bugs graves, você deve pedir à sua hospedagem para atualizar para uma versão mais recente. Joomla! versões 1.5.15 e posteriores são compatíveis com PHP 5.3. Note que a biblioteca OpenID não é compatível com PHP 5.3.

[5] Suporte para Microsoft SQL Server foi adicionado na versão 2.5. As versões 1.6 e 1.7 não têm esse suporte.

[6] Para o Microsoft IIS (dependendo da sua configuração), poderá ser necessário o seguinte:

Para assistência adicional sobre o uso do Microsoft IIS, consulte o Joomla! IIS forum.

Opções de Configuração

Se for instalar num computador local, existe uma série de pacotes de aplicações que ajudam a configurar mais rápido do que fazendo instalações individuais:

  • LAMP (Linux) - A maioria das distribuições Linux vem com um servidor LAMP pré-configurado.
  • WAMP (Windows) - Para mais informações, consulte a página do WampServer
  • MAMP (Apple OS) - Para mais informações, consulte a página do MAMP
  • XAMPP (multi-plataforma) - Não utilizar em sites em produção. Para mais informações, consulte a página do XAMPP

Se precisar de outras opções, recomendamos visitar nossos fóruns de instalação para mais informações, ou verificar nossa lista de requisitos técnicos opcionais.