Alle anbefalede versioner er baseret på den nyeste version af hver serie.

Krav til understøttet software

Krav til Joomla! 3.x

Software Anbefalet Minimum Mere information
PHP[1]
(Magic Quotes GPC, MB String Overload = off)
(Zlib Compression Support, XML Support, INI Parser Support, JSON Support, Mcrypt Support, MB Language = Default)
5.6 or 7.0 + 5.3.10 https://secure.php.net
Understøttede databaser:
MySQL[2]
(InnoDB support required)
5.5.3 + 5.1 https://www.mysql.com
SQL Server 10.50.1600.1 + 10.50.1600.1 https://www.microsoft.com/sql
PostgreSQL 9.1 + 8.3.18 https://www.postgresql.org/
Understøttede web-servere:
Apache[3]
(with mod_mysql, mod_xml, and mod_zlib)
2.4 + 2.0 https://www.apache.org
Nginx 1.8 + 1.0 https://www.nginx.com/resources/wiki/
Microsoft IIS[6] 7 7 https://www.iis.net

Krav til ikke-understøttet software

Krav til Joomla! 1,6, 1.7 og 2.5 - Understøttelse sluttede den 31. December 2014

Software Anbefalet Minimum Mere information
PHP 5.6 5.2.4 https://secure.php.net
Understøttede databaser:
MySQL 5.0.4 + 5.0.4 https://www.mysql.com
SQL Server[5] 10.50.1600.1 + 10.50.1600.1 https://www.microsoft.com/sql
Understøttede web-servere:
Apache[3]
(with mod_mysql, mod_xml, and mod_zlib)
2.2 + 2.0 https://www.apache.org
Nginx 1.1 + 1.0 https://www.nginx.com/resources/wiki/
Microsoft IIS[6] 7 7 https://www.iis.net

Krav til Joomla! 1.5 - Understøttelse sluttede den 31 December 2012

Software Anbefalet Minimum Mere information
PHP[4] 5.3 4.3.10 https://secure.php.net
Understøttede databaser:
MySQL 4.1.x + 3.23 https://www.mysql.com
Understøttede web-servere:
Apache[3]
(with mod_mysql, mod_xml, and mod_zlib)
2.0 + 1.3 https://www.apache.org
Microsoft IIS[6] 7 6 https://www.iis.net

Krav til Joomla! 1,0 - Understøttelse sluttede den 22 juli 2009

Software Anbefalet Minimum Mere information
PHP[4] 5.3 4.2 https://secure.php.net
Understøttede databaser:
MySQL 4.1.x + 3.23 https://www.mysql.com
Understøttede web-servere:
Apache[3]
(with mod_mysql, mod_xml, and mod_zlib)
2.x + 1.3 https://www.apache.org
Microsoft IIS[6] 7 6 https://www.iis.net

Fodnoter

[1] PHP 5.3.1 kræves for versioner 3.0 til 3.2. På 3,3, er minimum, der er hævet til PHP 5.3.10. Joomla! version 3.5 og nyere versioner er kompatible med PHP 7.

[2] fra Joomla! 3.5, understøttelse af Mysql's 'utf8mb4' tegnsæt er tilføjet og bruges som standard af servere, som understøtter det

[3] for at bruge SEO URLs, skal du have Apache mod_rewrite udvidelsen installeret.

[4] brug ikke PHP 4.3.9, 4.4.2 eller 5.0.4. Disse udgivelser har kendte fejl, der vil forstyrre installationen. Zend Optimizer 2.5.10 til PHP 4.4 har også alvorlige fejl og du bør spørge din host om at opgradere til en nyere version. Joomla! versioner 1.5.15 og senere er kompatible med PHP 5.3. Bemærk, at biblioteket OpenID ikke er kompatibel med PHP 5.3.

[5] understøttelse af Microsoft SQL Server blev tilføjet til 2,5 udgivelsen; 1,6 og 1,7 har ikke denne understøttelse.

[6] For Microsoft IIS (afhængigt af din opsætning) kan du bruge følgende:

For yderligere hjælp til brug af Microsoft IIS, kan du besøge Joomla! IIS forum.

Konfigurationsindstillinger

Hvis du installerer på en lokal computer, er der en række pakker, der vil hjælpe dig med at få oprettet hurtigere end ved individuelle installationer:

  • LAMP (Linux) - de fleste Linux distributioner kommer med en pre-konfigureret LAMP-server.
  • WAMP (Windows) - For mere information, besøg WampServer hjemmeside
  • MAMP (Apple OS) - For mere information, besøg MAMP hjemmeside
  • XAMPP (multiplatformsadgang) - ikke for live sites. For mere information, besøg XAMPP hjemmesiden

Hvis du har brug for andre muligheder, anbefaler vi at besøge vores installation fora for mere information eller tjekke vores liste over valgfri tekniske krav.