كافة النسخ الموصى بها تعتمد على أحدث نسخة إصدار لكل سلسلة.

المتطلبات للبرامج المدعومة

متطلبات Joomla! 3.x

البرمجيات موصى به الحد الأدنى معلومات اكثر
PHP[1] 7.1 + 5.3.10 (Magic Quotes GPC, MB String Overload = مطفأة)
(Zlib Compression Support, XML Support, INI Parser Support, JSON Support, Mcrypt Support, MB Language = الإفتراضي)
قواعد البيانات المدعومة
MySQL[2] 5.5.3 + 5.1 (InnoDB الدعم المطلوب)
SQL Server 10.50.1600.1 + 10.50.1600.1 https://www.microsoft.com/sql
PostgreSQL 9.1 + 8.3.18 https://www.postgresql.org/
مخدمات ويب المدعومة
Apache[3] 2.4 + 2.0 (مع mod_mysql و mod_xml و mod_zlib)
Nginx 1.8 + 1.0 https://www.nginx.com/resources/wiki/
Microsoft IIS[6] 7 7 https://www.iis.net
يرجى الاطلاع على https://docs.joomla.org/Joomla_Browser_Support للحصول على قائمة بالمتصفحات المدعومة في Joomla 3.x.

متطلبات للبرامج الغير مدعومة

متطلبات Joomla! 1.6, 1.7, & 2.5

الدعم لهذا الإصدار من Joomla! قد انتهى في 31 كانون1/ديسمبر 2014
البرمجيات موصى به الحد الأدنى معلومات اكثر
PHP 5.6 5.2.4 https://secure.php.net
قواعد البيانات المدعومة
MySQL 5.0.4 + 5.0.4 https://www.mysql.com
SQL Server[5] 10.50.1600.1 + 10.50.1600.1 https://www.microsoft.com/sql
مخدمات ويب المدعومة
Apache[3] 2.2 + 2.0 (مع mod_mysql و mod_xml و mod_zlib)
Nginx 1.1 + 1.0 https://www.nginx.com/resources/wiki/
Microsoft IIS[6] 7 7 https://www.iis.net

متطلبات Joomla! 1.5

الدعم لهذا الإصدار من Joomla! قد انتهى في 31 كانون1/ديسمبر 2012
البرمجيات موصى به الحد الأدنى معلومات اكثر
PHP[4] 5.3 4.3.10 https://secure.php.net
قواعد البيانات المدعومة
MySQL 4.1.x + 3.23 https://www.mysql.com
مخدمات ويب المدعومة
Apache[3] 2.0 + 1.3 (مع mod_mysql و mod_xml و mod_zlib)
Microsoft IIS[6] 7 6 https://www.iis.net

متطلبات Joomla! 1.0

الدعم لهذا الإصدار من Joomla! قد انتهى في 22 تموز/يوليو 2009
البرمجيات موصى به الحد الأدنى معلومات اكثر
PHP[4] 5.3 4.3.10 https://secure.php.net
قواعد البيانات المدعومة
MySQL 4.1.x + 3.23 https://www.mysql.com
مخدمات ويب المدعومة
Apache[3] 2.0 + 1.3 (مع mod_mysql و mod_xml و mod_zlib)
Microsoft IIS[6] 7 6 https://www.iis.net

الحواشي السفلية

[1] مطلوب نسخة PHP 5.3.1 للاصدارات 3.0 الى 3.2. اعتبارا من 3.3، تم رفع الحد الأدنى الى PHP 5.3.10. اصدار Joomla! 3.5 وما بعد متوافق مع PHP 7.

[2] اعتبارا Joomla! 3.5, تم إضافة دعم مجموعة محارف `utf8mb4` لـ MySQL's واستخدامها بشكل افتراضي من قبل المخدمات التي تدعم ذلك.

[3] من أجل استخدام SEO URLs, سوف تحتاج إلى تثبيت ملحق Apache mod_rewrite.

[4] لاتستخدم PHP 4.3.9 أو 4.4.2 أو 5.0.4. هذه الاصدارات لديها ثغرات معروفة والتي تتعارض مع التثبيت. Zend Optimizer 2.5.10 لـ PHP 4.4 لديه ثغرات خطيرة أيضا وينبغي ان تسأل المضيف الخاص بك للترقية الى الاصدار الجديد. Joomla! إصدارات 1.5.15 وما بعد ذلك هي متوافقة مع PHP 5.3. علما أن المكتبة OpenID ليست متوافقة مع PHP 5.3.

[5] تم اضافة الدعم لـ Microsoft SQL Server للاصدار 2.5; 1.6 و 1.7 لاتملك هذا الدعم.

[6] لـ Microsoft IIS (اعتماداً على الإعداد الخاص بك) قد تحتاج إلى ما يلي:

لمزيد من المساعدة باستخدام Microsoft IIS، قم بزيارة منتدى Joomla! IIS .

خيارات الاعداد

في حالة تثبيته على جهاز كمبيوتر محلي، هناك عدد من الحزم التي سوف تساعدك على إعداده أسرع من التثبيتات الفردية:

إذا كنت بحاجة إلى خيارات أخرى، نوصي بزيارة منتديات التثبيت لمزيد من المعلومات أو التحقق من قائمتنا للمتطلبات التقنية الاختيارية.