Sve preporučene verzije temelje se na posljednjoj izdanoj verziji iz svake serije.

Zahtjevi za podržani softver

Zahtjevi za Joomla! 3.x

Softver Preporučeno Minimum Više informacija
PHP[1]
(Magic Quotes GPC, MB String Overload = off)
(Zlib Compression Support, XML Support, INI Parser Support, JSON Support, Mcrypt Support, MB Language = Default)
5.6 or 7.0 + 5.3.10 https://secure.php.net
Podržane baze podataka:
MySQL[2]
(neophodna InnoDB podrška)
5.5.3 + 5.1 https://www.mysql.com
SQL Server 10.50.1600.1 + 10.50.1600.1 https://www.microsoft.com/sql
PostgreSQL 9.1 + 8.3.18 https://www.postgresql.org/
Podržani web serveri:
Apache[3]
(sa mod_mysql, mod_xml, i mod_zlib)
2.4 + 2.0 https://www.apache.org
Nginx 1.8 + 1.0 https://www.nginx.com/resources/wiki/
Microsoft IIS[6] 7 7 https://www.iis.net

Zahtjevi za nepodržani softver

Zahtjevi za Joomla! 1.6, 1.7 i 2.5 - Podrška je završila 31. prosinca 2014.

Softver Preporučeno Minimum Više informacija
PHP 5.6 5.2.4 https://secure.php.net
Podržane baze podataka:
MySQL 5.0.4 + 5.0.4 https://www.mysql.com
SQL Server[5] 10.50.1600.1 + 10.50.1600.1 https://www.microsoft.com/sql
Podržani web serveri:
Apache[3]
(sa mod_mysql, mod_xml, i mod_zlib)
2.2 + 2.0 https://www.apache.org
Nginx 1.1 + 1.0 https://www.nginx.com/resources/wiki/
Microsoft IIS[6] 7 7 https://www.iis.net

Zahtjevi za Joomla! 1.5 - Podrška je završila 31. prosinca 2012.

Softver Preporučeno Minimum Više informacija
PHP[4] 5.3 4.3.10 https://secure.php.net
Podržane baze podataka:
MySQL 4.1.x + 3.23 https://www.mysql.com
Podržani web serveri:
Apache[3]
(sa mod_mysql, mod_xml, i mod_zlib)
2.0 + 1.3 https://www.apache.org
Microsoft IIS[6] 7 6 https://www.iis.net

Zahtjevi za Joomla! 1.0 - Podrška je završila 22. srpnja 2009.

Softver Preporučeno Minimum Više informacija
PHP[4] 5.3 4.2 https://secure.php.net
Podržane baze podataka:
MySQL 4.1.x + 3.23 https://www.mysql.com
Podržani web serveri:
Apache[3]
(sa mod_mysql, mod_xml, i mod_zlib)
2.x + 1.3 https://www.apache.org
Microsoft IIS[6] 7 6 https://www.iis.net

Fusnote

[1] PHP 5.3.1 je potreban za verzije 3.0 do 3.2. S verzijom 3.3, minimum je podignut na PHP 5.3.10. Joomla! verzije 3.5 i kasnije kompatibilne su s PHP 7.

[2] Od Joomla! 3.5, dodana je podrška za MySQL `utf8mb4` skup znakova i koristi se kao zadana na serverima koji ga podržavaju

[3] Za korištenje SEO URLova, trebate imati instaliran Apache mod_rewrite dodatak.

[4] Nemojte koristiti PHP 4.3.9, 4.4.2 ili 5.0.4. Ova izdanja imaju poznate greške koje će ometati instalaciju. Zend Optimizer 2.5.10 za PHP 4.4 također ima ozbiljne greške i trebali bi zatražiti svog hosting davatelja usluga za ažuriranje na noviju verziju. Joomla! verzija 1.5.15 i kasnije su kompatibilne s PHP 5.3. Imajte na umu da OpenID biblioteka nije kompatibilna s PHP 5.3.

[5] Podrška za Microsoft SQL Server je dodana za 2.5 izdanje; 1.6 i 1.7 nemaju ovu podršku.

[6] Za Microsoft IIS (ovisno o postavkama) možda ćete trebati sljedeće:

Za daljnju pomoć oko korištenja Microsoft IIS, posjetite Joomla! IIS forum.

Opcije konfiguracije

Ako instalirate na lokalno računalo, postoji nekoliko paketa koje će vam pomoći pri bržem podešavanju nego pojedinačne instalacije:

  • LAMP (Linux) - većina Linux distribucija dolazi s unaprijed pre-konfiguriranim LAMP serverom.
  • WAMP (Windows) - za više informacija, posjetite WampServer stranicu
  • MAMP (Apple OS) - za više informacija, posjetite MAMP stranicu
  • XAMPP (multi-platforma) - nije za produkcijske stanice. Za više informacija, posjetite XAMPP stranicu

Ako trebate druge opcije, preporučujemo da posjetite naše instalacijske forume za više informacija ili provjerite naš popis dodatnih tehničkih zahtjeva.