Minden ajánlott változat alapja minden egyes sorozat legújabb kiadása.

Támogatott szoftver követelményei

Követelmények a Joomla! 3.x-hez

Szoftver Ajánlott Minimum További információ
PHP [1]
(Magic Quotes GPC, MB String Overload = off)
(Zlib Compression Support, XML Support, INI Parser Support, JSON Support, Mcrypt Support, MB Language = Default)
5.6 vagy 7.0 + 5.3.10 https://secure.php.net
Támogatott adatbázisok:
MySQL [2]
(InnoDB támogatás szükséges)
5.5.3 + 5.1 https://www.mysql.com
SQL Server 10.50.1600.1 + 10.50.1600.1 https://www.microsoft.com/sql
PostgreSQL 9.1 + 8.3.18 https://www.postgresql.org/
Támogatott Web szerverek:
Apache[3]
(telepítve a mod_mysql, mod_xml, és mod_zlib)
2.4 + 2.0 https://www.apache.org
Nginx 1.8 + 1.0 https://www.nginx.com/resources/wiki/
Microsoft IIS[6] 7 7 https://www.iis.net

Nem támogatott szoftver követelményei

Műszaki küvetelmények a Joomla! 1.6, 1.7, & 2.5 verziókhoz - A támogatás megszünt 2014 december 31-én

Szoftver Ajánlott Minimum További információ
PHP 5.6 5.2.4 https://secure.php.net
Támogatott adatbázisok:
MySQL 5.0.4 + 5.0.4 https://www.mysql.com
SQL Server[5] 10.50.1600.1 + 10.50.1600.1 https://www.microsoft.com/sql
Támogatott Web szerverek:
Apache [3]
(mod_mysql, mod_xml, és mod_zlib)
2.2 + 2.0 https://www.apache.org
Nginx 1.1 + 1.0 https://www.nginx.com/resources/wiki/
Microsoft IIS[6] 7 7 https://www.iis.net

Joomla! 1.5 követelmények - a terméktámogatás 2012 december 31-én megszünt

Szoftver Ajánlott Minimum További információ
PHP[4] 5.3 4.3.10 https://secure.php.net
Támogatott adatbázisok:
MySQL 4.1.x + 3.23 https://www.mysql.com
Támogatott Web szerverek:
Apache [3]
(mod_mysql, mod_xml, és mod_zlib)
2.0 + 1.3 https://www.apache.org
Microsoft IIS[6] 7 6 https://www.iis.net

Joomla! 1.0 követelmények- a terméktámogatás 2009 július 22-én megszünt

Szoftver Ajánlott Minimum További információ
PHP[4] 5.3 4.2 https://secure.php.net
Támogatott adatbázisok:
MySQL 4.1.x + 3.23 https://www.mysql.com
Támogatott Web szerverek:
Apache [3]
(mod_mysql, mod_xml, és mod_zlib)
2.x + 1.3 https://www.apache.org
Microsoft IIS[6] 7 6 https://www.iis.net

Lábjegyzetek

[1] PHP 5.3.1 kötelező a 3.0-3.2-es verziókhoz. A 3.3-as verziótól a minimális követelmény a PHP 5.3.10. A 3.5 verziótól a Joomla! minden verziója kompatibilis a PHP 7-el.

[2] A Joomla! 3.5-től a MySQL `utf8mb4` karakterkészlet is elérhető és alapértelmezett minden szerveren, ami ezt támogatja

[3] A keresőbarát URL-k használatos az Apache mod_rewrite kiterjesztésének engedélyezve kell lennie.

[4] Ne használd a PHP 4.3.9, 4.4.2 vagy 5.0.4 verzióját. Ezeknek ismert hibái vannak, amelyek a telepített Joomlával összeférhetetlenek. A Zend Optimizer 2.5.10 a PHP 4.4-hez komoly hibákat tartalmaz, és kérned kell a tárhely-szolgáltatódtól, hogy frissítse egy újabb verzióra. A Joomla! a 1.5.15 verziótól kompatibilis a PHP 5.3-el. Figyelem, az OpenID könyvtár nem kompatibilis a PHP 5.3-al.

[5]A Microsoft SQL Server támogatás a 2.5-es verziótól része az alapcsomagnak; az 1.6 és 1.7 verziók nem tartalmazzák ezt a támogatást.

[6] A Microsoft IIS használatához (a telepítési környezettől függően) az alábbiakra lehet szükséged:

További segítségért a Microsoft IIS használatához látogasson el a Joomla! IIS fórumra.

Konfigurációs beállítások

Ha helyi gépre telepíted, egy pár szoftvercsomag valamelyike ajánlott ahhoz, hogy gyorsabban és könnyebben telepíthesd a Joomlát:

  • LAMP (Linux) - a legtöbb Linux disztribúció tartalmaz egy előre konfigurált LAMP szervert.
  • WAMP (Windows) - további információért keresse fel a WampServer honlapját
  • MAMP (Apple OS) - további információért keresse fel a MAMP honlapját
  • XAMPP (multi-platform) - nem ajánlott élő webhlyek számára. További információért keresse fel az XAMPP honlapját

Ha más opciókra volna szükséged, látogasd meg a telepítési fórumainkat további információkért, vagy olvasd el az opcionális műszaki követelmények listáját.