Kõik soovitatud versioonid põhinevad iga seeria viimasele versioonil.

Nõuded toetatud tarkvarale

Nõuded Joomla! 3.x-le

Tarkvara Soovituslik Minimaalne Rohkem infot
PHP[1]
(Magic Quotes GPC, MB String Overload = off)
(Zlib Compression Support, XML Support, INI Parser Support, JSON Support, Mcrypt Support, MB Language = Default)
5.6 or 7.0 + 5.3.10 https://secure.php.net
Toetatud andmebaasid:
MySQL[2]
(nõutud on InnoDB)
5.5.3 + 5.1 https://www.mysql.com
SQL Server 10.50.1600.1 + 10.50.1600.1 https://www.microsoft.com/sql
PostgreSQL 9.1 + 8.3.18 https://www.postgresql.org/
Toetatud veebiserverid:
Apache[3]
(moodulitega mod_mysql, mod_xml ja mod_zlib)
2.4 + 2.0 https://www.apache.org
Nginx 1.8 + 1.0 https://www.nginx.com/resources/wiki/
Microsoft IIS[6] 7 7 https://www.iis.net

Nõuded tarkvarale, mida enam ei toetata

Nõuded Joomla! 1.5, 1.7 ja 2.5 jaoks - Tugi lõppes 31. detsembril 2014

Tarkvara Soovituslik Minimaalne Rohkem infot
PHP 5.6 5.2.4 https://secure.php.net
Toetatud andmebaasid:
MySQL 5.0.4 + 5.0.4 https://www.mysql.com
SQL Server[5] 10.50.1600.1 + 10.50.1600.1 https://www.microsoft.com/sql
Toetatud veebiservereid:
Apache[3]
(moodulitega mod_mysql, mod_xml ja mod_zlib)
2.2 + 2.0 https://www.apache.org
Nginx 1.1 + 1.0 https://www.nginx.com/resources/wiki/
Microsoft IIS[6] 7 7 https://www.iis.net

Nõuded Joomla! 1.5-le - Tugi lõppes 31. detsembril 2012

Tarkvara Soovituslik Minimaalne Rohkem infot
PHP[4] 5.3 4.3.10 https://secure.php.net
Toetatud andmebaasid:
MySQL 4.1.x + 3.23 https://www.mysql.com
Toetatud veebiservereid:
Apache[3]
(moodulitega mod_mysql, mod_xml ja mod_zlib)
2.0 + 1.3 https://www.apache.org
Microsoft IIS[6] 7 6 https://www.iis.net

Nõuded Joomla! 1.0-le - Tugi lõppes 22. juulil 2009

Tarkvara Soovituslik Minimaalne Rohkem infot
PHP[4] 5.3 4.2 https://secure.php.net
Toetatud andmebaasid:
MySQL 4.1.x + 3.23 https://www.mysql.com
Toetatud veebiservereid:
Apache[3]
(moodulitega mod_mysql, mod_xml ja mod_zlib)
2.x + 1.3 https://www.apache.org
Microsoft IIS[6] 7 6 https://www.iis.net

Allmärkused

[1] PHP 5.3.1 on nõutud versioonidele 3.0 kuni 3.2. Alates versioonist 3.3 on miinimumnõue PHP 5.3.10. Joomla! versioonid 3.5 ja hilisemad ühilduvad PHP 7-ga.

[2] Alates Joomla! 3.5-st toetatakse MySQL-i `utf8mb4` kooditabelit ja seda kasutatakse vaikimisi serveritel, mis seda toetavad

[3] Otsingumootori sõbralike URL-ide kasutamiseks peab Apache serveris olema paigaldatud moodul mod_rewrite.

[4] Ära kasuta PHP versioone 4.3.9, 4.4.2 või 5.0.4. Neis versioonides on vead, mis takistavad paigaldamist. Zend Optimizer 2.5.10 PHP 4.4 jaoks on ka tõsiseid vigasid ning sa peaksid paluma oma veebiteenuse osutajal seda uuendada uuemale versioonile. Joomla! versioonid 1.5.15 ja hilisemad versioonid ühilduvad PHP 5.3-ga. Pea meeles, et OpenID teek ei ühildu PHP 5.3-ga.

[5] Microsoft SQL serveri tugi lisati versioonis2.5; 1.6 ja 1.7 seda ei toeta.

[6] Microsoft IIS-i jaoks võid sa (sõltuvalt sinu seadistusest) vajada järgnevat:

Lisainfot Microsoft IIS-i kasutamiseks vaata Joomla! IIS foorumist.

Seadistamise valikud

Kui sa paigaldad Joomlat oma arvutisse, siis võid kasutada mitmeid valikuid, mis aitavad sul teha paigaldamise kergemaks:

  • LAMP (Linux) - Enamikud Linux distributsioonidel on olemas eelseadistatud LAMP serverid.
  • WAMP (Windows) - Vaata lisainfot WampServeri kodulehelt
  • MAMP (Apple OS) - Lisainfot vaata MAMP-i kodulehelt
  • XAMPP (platform) - Pole mõeldud live saitide jaoks. Lisainfot vaata XAMPP-i kodulehelt

Kui sul on vaja muid valikuid, siis külasta lisainfo saamiseks meie paigaldamise foorumeid või kontrolli meie valikuliste tehniliste nõuete nimekirja.